Tolkien Collector's Guide
eBay auction images

eBay auction images

Joined:
May 27, 2006
From California, USA
Group:
Thain
Shirefolk
Fellowship
Posts: 1827

So....

I have added code to the site that will recognize eBay auction links in forum posts (new posts moving forward), then go out and grab the primary image for that auction, save a copy locally, and attach it to the forum post.

All automatic, just works from (pretty much any) eBay auction link that you include in your post.

It is still a wee bit buggy so just let me know if you see any funny stuff.

I now need to grab more images (a lot of times the first image is not the best to save away) if I can figure out a good way to do that. So please still attach images to your forum posts if you think of it.

In the meantime, this should help us moving forward. :)
_________________
- Jeremy


Re: eBay auction images

Joined:
Jun 6, 2006
From Essex, England
Group:
Shirefolk
Fellowship
Shirrif
Posts: 2282

That's great, I think Khamul and myself will also moderate posts to include images, if they are missing, going forward.

Looks like a few problems still, tried to add an image to garm's post

http://www.tolkienguide.com/modules/n ... ost_id=7494#forumpost7494


Re: eBay auction images

Joined:
May 27, 2006
From California, USA
Group:
Thain
Shirefolk
Fellowship
Posts: 1827

Thanks Trotter (and Khamul)! More helping hands only makes the site that much better overall, and making sure the images get archived is really important as we are all figuring out.

I will go back through my browsing archives and see if I have images from any of the older threads on my local hard drive.

On the thread you tried to update: there are two issues.

One is that every time you edit the thread, it finds another ebay link (the one it added automatically the last time) and so tries to add another image! That is why there were three links there. Major bug, and I will have that fixed tonight.

Second issue - the image link is correct (and viewable if you copy/paste it) but the special characters that eBay uses for image names (the parenthesis) cause the forum browser to not render the link correctly! Another bug that I think I have a solution for, will try that out tonight.

Thanks for the help!
_________________
- Jeremy


Re: eBay auction images

Joined:
May 27, 2006
From California, USA
Group:
Thain
Shirefolk
Fellowship
Posts: 1827

All right, looks like both bugs are fixed for now. I have more ideas to make this more robust over time, so let me know if you have thoughts on making it better and I will see what I can do.

Bug reports are of course welcome as well!
_________________
- Jeremy



All original content © 2018 by the submitting authors. Terms of Use | Privacy Policy | Cookie Policy | Contact Us